<!DOCTYPE html>
<html lang="en-US"
 xmlns:og="http://ogp.me/ns#"
 xmlns:fb="http://ogp.me/ns/fb#" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://www.whatthebuc.net/xmlrpc.php">

<title>Welcome Aboard, Beau Allen! - What The Buc?</title>
<script>window._wca = window._wca || [];</script>
<!-- Site designed and built by Dual Brain. -->
<meta name='designer' content='Dual Brain'>
<meta name='designer_url' content='http://ThinkDualBrain.com/'>
<meta name='web_author' content='Dual Brain'>
<meta name='web_author_url' content='http://ThinkDualBrain.com/'>
<meta name='site_ref_sig' content='==DB=='>
<!-- Site designed and built by Dual Brain. -->

<!-- This site is optimized with the Yoast SEO plugin v7.5.3 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Welcome Aboard, Beau Allen! - What The Buc?" />
<meta property="og:description" content="The first free agent acquisition of the 2018 offseason was a bit of a surprise. When the news came out that the Buccaneers had signed former Eagles defensive tackle Beau Allen, my first reaction was&#8230;&#8220;WHO???&#8221;.  However, after Googling him, I found that the 26-year-old Allen fits into the Bucs new blue-collar mauler philosophy for their ...Read More" />
<meta property="og:url" content="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/" />
<meta property="og:site_name" content="What The Buc?" />
<meta property="article:publisher" content="http://www.facebook.com/whatthebuc" />
<meta property="article:author" content="Deez Bucz" />
<meta property="article:tag" content="2018 BUCS FREE AGENTS" />
<meta property="article:tag" content="Beau Allen" />
<meta property="article:tag" content="bucs defense" />
<meta property="article:tag" content="philadelphia eagles" />
<meta property="article:tag" content="Tampa Bay Buccaneers" />
<meta property="article:tag" content="Vita Vea" />
<meta property="article:section" content="Features" />
<meta property="article:published_time" content="2018-06-23T08:00:54-04:00" />
<meta property="article:modified_time" content="2018-06-22T19:23:12-04:00" />
<meta property="og:updated_time" content="2018-06-22T19:23:12-04:00" />
<meta property="og:image" content="http://www.whatthebuc.net/wp-content/uploads/2018/05/N0654-TBB_1_56289501-d975-4b82-83db-53f92a12cb2f_580x.jpg" />
<meta property="og:image:width" content="579" />
<meta property="og:image:height" content="283" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The first free agent acquisition of the 2018 offseason was a bit of a surprise. When the news came out that the Buccaneers had signed former Eagles defensive tackle Beau Allen, my first reaction was&#8230;&#8220;WHO???&#8221;.  However, after Googling him, I found that the 26-year-old Allen fits into the Bucs new blue-collar mauler philosophy for their ...Read More" />
<meta name="twitter:title" content="Welcome Aboard, Beau Allen! - What The Buc?" />
<meta name="twitter:site" content="@WhatTheBuc" />
<meta name="twitter:image" content="http://www.whatthebuc.net/wp-content/uploads/2018/05/N0654-TBB_1_56289501-d975-4b82-83db-53f92a12cb2f_580x.jpg" />
<meta name="twitter:creator" content="@Bucz" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="What The Buc? &raquo; Feed" href="http://www.whatthebuc.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="What The Buc? &raquo; Comments Feed" href="http://www.whatthebuc.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="What The Buc? &raquo; Welcome Aboard, Beau Allen! Comments Feed" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.whatthebuc.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
		<style type="text/css">
				</style>
	<link rel='stylesheet' id='woocommerce-layout-css'  href='/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?ver=3.4.1' type='text/css' media='all' />
<style id='woocommerce-layout-inline-css' type='text/css'>

	.infinite-scroll .woocommerce-pagination {
		display: none;
	}
</style>
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=3.4.1' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css'  href='/wp-content/plugins/woocommerce/assets/css/woocommerce.css?ver=3.4.1' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='nextend_fb_connect_stylesheet-css'  href='/wp-content/plugins/nextend-facebook-connect/providers/facebook/compat/buttons/facebook-btn.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='nextend_twitter_connect_stylesheet-css'  href='/wp-content/plugins/nextend-facebook-connect/providers/twitter/compat/buttons/twitter-btn.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='printful-global-css'  href='/wp-content/plugins/printful-shipping-for-woocommerce/includes/../assets/css/global.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='dualbrain-v4-fonts-css'  href='//fonts.googleapis.com/css?family=Lato%3A400%2C300%2C100%2C700%2C900%7CMontserrat%3A400%2C700&#038;ver=2.1' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='dualbrain-v4-style-css'  href='/wp-content/themes/whatthebuc-v2/style.css?ver=2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-featherlight-css'  href='/wp-content/plugins/wp-featherlight/css/wp-featherlight.min.css?ver=1.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='wppress-fb-calendar-css'  href='/wp-content/plugins/facebook-events/css/facebook-events.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='/wp-content/plugins/jetpack/css/jetpack.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-author-bio-css'  href='/wp-content/plugins/wp-about-author/wp-about-author.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='wp-paginate-css'  href='/wp-content/plugins/wp-paginate/css/wp-paginate.css?ver=2.0.4' type='text/css' media='screen' />
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/www.whatthebuc.net\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='http://www.whatthebuc.net/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.whatthebuc.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='http://www.whatthebuc.net/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.6-78496d1'></script>
<script type='text/javascript' src='http://www.whatthebuc.net/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=4.9.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<link rel='https://api.w.org/' href='http://www.whatthebuc.net/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.whatthebuc.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.whatthebuc.net/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.6" />
<meta name="generator" content="WooCommerce 3.4.1" />
<link rel='shortlink' href='http://www.whatthebuc.net/?p=14465' />
<link rel="alternate" type="application/json+oembed" href="http://www.whatthebuc.net/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.whatthebuc.net%2F2018%2F06%2F23%2Fwelcome-aboard-beau-allen%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.whatthebuc.net/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.whatthebuc.net%2F2018%2F06%2F23%2Fwelcome-aboard-beau-allen%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.14 Professional to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:1px 1px 1px 1px; }
	.g-2 { min-width:1px; max-width:142px; }
	.b-2 { margin:1px 1px 1px 1px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<meta property="fb:app_id" content="836997632991653"/><script type="text/javascript">/* */if(typeof WPPress=="undefined"){var WPPress={};}WPPress.adminajax="http://www.whatthebuc.net/wp-admin/admin-ajax.php";WPPress.facebooEventsCalendar="/wp-content/plugins/facebook-events/";WPPress.weekoffset=0;WPPress.FBCalTimezone="US/Eastern";WPPress.calendar={locale:{},lang:"en_US"};WPPress.calendar.locale.months=["January","February","March","April","May","June","July","August","September","October","November","December"];WPPress.calendar.locale.monthsShort  =["January","February","March","April","May","June","July","August","September","October","November","December"];WPPress.calendar.locale.weekdays =["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"];WPPress.calendar.locale.weekdaysShort =["Sun","Mon","Tue","Wed","Thu","Fri","Sat"];WPPress.calendar.locale.weekdaysMin =["S","M","T","W","T","F","S"];/* */</script><script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
<link rel="alternate" type="application/rss+xml" title="Default Podcast Feed" href="http://www.whatthebuc.net/feed/podcast/" />

<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

	<script>
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
				(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

		ga('create', 'UA-10155661-1', 'auto');
		ga('send', 'pageview');

	</script>
	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	<script async src='https://stats.wp.com/s-201825.js'></script>
</head>

<body class="post-template-default single single-post postid-14465 single-format-standard woocommerce-no-js wp-featherlight-captions group-blog">
<div id="wrapper" class="site">
	<a class="skip-link screen-reader-text" href="#main">Skip to content</a>

	<header id="mobile-header" role="banner" class="mobile-header header clearfix hidden-md hidden-lg hidden-xl hidden-print"  data-spy="affix" data-offset-top="100">

		<div id="masthead" class="branding masthead">
			<div class="container">

				<div id="site-branding" class="branding site-branding col-xxs-12 col-xs-12 text-center">

					<a id="mobile-logo" href="http://www.whatthebuc.net/" title="What The Buc?" rel="home" class="logo inline-block"><img src="/wp-content/themes/whatthebuc-v2/images/what-the-buc-logo-mini.svg" class="img-responsive" alt="What The Buc?" /></a>

				</div>

			</div><!-- .container -->
		</div><!-- #masthead -->

		<div id="mobile-header-menu" class="clearfix">
			<div id="mobile-menu-body" class="collapse">
				<div class="panel-body">
					<div id="mobile-header-search-panel" class="col-xs-12 text-right">
						<form role="search" method="get" id="search" class="search form search-form" action="http://www.whatthebuc.net/">
	<input type="text" value="" name="s" id="search-input" class="search input search-input" placeholder="Search" />
	<button type="submit" id="search-submit" class="search submit search-submit">
		<svg version="1.1" id="Capa_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
		     viewBox="0 0 250.313 250.313" style="enable-background:new 0 0 250.313 250.313;" xml:space="preserve">
			<g id="Search">
				<path d="M244.186,214.604l-54.379-54.378c-0.289-0.289-0.628-0.491-0.93-0.76
					c10.7-16.231,16.945-35.66,16.945-56.554C205.822,46.075,159.747,0,102.911,0S0,46.075,0,102.911
					c0,56.835,46.074,102.911,102.91,102.911c20.895,0,40.323-6.245,56.554-16.945c0.269,0.301,0.47,0.64,0.759,0.929l54.38,54.38
					c8.169,8.168,21.413,8.168,29.583,0C252.354,236.017,252.354,222.773,244.186,214.604z M102.911,170.146
					c-37.134,0-67.236-30.102-67.236-67.235c0-37.134,30.103-67.236,67.236-67.236c37.132,0,67.235,30.103,67.235,67.236
					C170.146,140.044,140.043,170.146,102.911,170.146z"/>
			</g>
		</svg>
	</button>
</form>					</div>
					<nav id="mobile-header-nav-menu" role="navigation" class="nav navigation">
						<div id="panel-item-6059" class="panel panel-default menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">	<div class="panel-heading"><h4 id="menu-item-6059" class="panel-title" ><a class="collapsed" title="Listen" data-toggle="collapse" href="#submenu-6059" data-parent="#mobile-menu-dropdown">Listen <span class="caret"></span></a></h4></div><!-- /.panel-heading -->
<div id="submenu-6059" class="sub-menu panel-collapse collapse">

	<div class="panel-body">
<div id="panel-item-6063" class="panel panel-default menu-item menu-item-type-custom menu-item-object-custom">	<div class="panel-heading">	<h4 id="menu-item-6063" class="panel-title" ><a title="All Episodes" href="/podcast/">All Episodes</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

<div id="panel-item-6060" class="panel panel-default menu-item menu-item-type-taxonomy menu-item-object-show-type">	<div class="panel-heading">	<h4 id="menu-item-6060" class="panel-title" ><a title="Roundtables" href="http://www.whatthebuc.net/show-type/roundtables/">Roundtables</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

<div id="panel-item-6061" class="panel panel-default menu-item menu-item-type-taxonomy menu-item-object-show-type">	<div class="panel-heading">	<h4 id="menu-item-6061" class="panel-title" ><a title="Live Shows" href="http://www.whatthebuc.net/show-type/live-shows/">Live Shows</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

<div id="panel-item-6062" class="panel panel-default menu-item menu-item-type-taxonomy menu-item-object-show-type">	<div class="panel-heading">	<h4 id="menu-item-6062" class="panel-title" ><a title="Watercooler" href="http://www.whatthebuc.net/show-type/watercooler/">Watercooler</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

	</div><!-- .panel-body -->
</div>
</div><!-- /.panel -->

<div id="panel-item-6064" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page current_page_parent">	<div class="panel-heading"><h4 id="menu-item-6064" class="panel-title" ><a title="Blog" href="http://www.whatthebuc.net/blog/">Blog</a></h4></div><!-- /.panel-heading --></div><!-- /.panel -->

<div id="panel-item-6065" class="panel panel-default menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">	<div class="panel-heading"><h4 id="menu-item-6065" class="panel-title" ><a class="collapsed" title="Tailgate" data-toggle="collapse" href="#submenu-6065" data-parent="#mobile-menu-dropdown">Tailgate <span class="caret"></span></a></h4></div><!-- /.panel-heading -->
<div id="submenu-6065" class="sub-menu panel-collapse collapse">

	<div class="panel-body">
<div id="panel-item-6066" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page">	<div class="panel-heading">	<h4 id="menu-item-6066" class="panel-title" ><a title="Tailgate!" href="http://www.whatthebuc.net/tailgate/">Tailgate!</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

<div id="panel-item-6048" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page">	<div class="panel-heading">	<h4 id="menu-item-6048" class="panel-title" ><a title="Rules, Notes and Updates" href="http://www.whatthebuc.net/tailgate/rules/">Rules, Notes and Updates</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

<div id="panel-item-7151" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page">	<div class="panel-heading">	<h4 id="menu-item-7151" class="panel-title" ><a title="This Week&#039;s Tailgate Itinerary" href="http://www.whatthebuc.net/tailgate/weeks-tailgate-itinerary/">This Week&#8217;s Tailgate Itinerary</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

<div id="panel-item-6047" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page">	<div class="panel-heading">	<h4 id="menu-item-6047" class="panel-title" ><a title="Map" href="http://www.whatthebuc.net/tailgate/map/">Map</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

<div id="panel-item-6046" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page">	<div class="panel-heading">	<h4 id="menu-item-6046" class="panel-title" ><a title="Food" href="http://www.whatthebuc.net/tailgate/food/">Food</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

	</div><!-- .panel-body -->
</div>
</div><!-- /.panel -->

<div id="panel-item-11909" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page">	<div class="panel-heading"><h4 id="menu-item-11909" class="panel-title" ><a title="Our Sponsors" href="http://www.whatthebuc.net/our-sponsors/">Our Sponsors</a></h4></div><!-- /.panel-heading --></div><!-- /.panel -->

<div id="panel-item-6054" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown">	<div class="panel-heading"><h4 id="menu-item-6054" class="panel-title" ><a class="collapsed" title="About" data-toggle="collapse" href="#submenu-6054" data-parent="#mobile-menu-dropdown">About <span class="caret"></span></a></h4></div><!-- /.panel-heading -->
<div id="submenu-6054" class="sub-menu panel-collapse collapse">

	<div class="panel-body">
<div id="panel-item-6067" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page">	<div class="panel-heading">	<h4 id="menu-item-6067" class="panel-title" ><a title="About" href="http://www.whatthebuc.net/about/">About</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

<div id="panel-item-6057" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page">	<div class="panel-heading">	<h4 id="menu-item-6057" class="panel-title" ><a title="The Team" href="http://www.whatthebuc.net/about/team/">The Team</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

<div id="panel-item-6058" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page">	<div class="panel-heading">	<h4 id="menu-item-6058" class="panel-title" ><a title="Contact Us" href="http://www.whatthebuc.net/about/contact-us/">Contact Us</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

	</div><!-- .panel-body -->
</div>
</div><!-- /.panel -->

<div id="panel-item-6053" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown">	<div class="panel-heading"><h4 id="menu-item-6053" class="panel-title" ><a class="collapsed" title="WTB Really Matters" data-toggle="collapse" href="#submenu-6053" data-parent="#mobile-menu-dropdown">WTB Really Matters <span class="caret"></span></a></h4></div><!-- /.panel-heading -->
<div id="submenu-6053" class="sub-menu panel-collapse collapse">

	<div class="panel-body">
<div id="panel-item-14979" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page">	<div class="panel-heading">	<h4 id="menu-item-14979" class="panel-title" ><a title="2018 School Supply Drive" href="http://www.whatthebuc.net/2017-school-supply-drive-2/">2018 School Supply Drive</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

<div id="panel-item-11490" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page">	<div class="panel-heading">	<h4 id="menu-item-11490" class="panel-title" ><a title="WTB Really Matters" href="http://www.whatthebuc.net/contribute/wtb-really-matters/">WTB Really Matters</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

	</div><!-- .panel-body -->
</div>
</div><!-- /.panel -->

<div id="panel-item-6090" class="panel panel-default menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown">	<div class="panel-heading"><h4 id="menu-item-6090" class="panel-title" ><a class="collapsed" title="Support" data-toggle="collapse" href="#submenu-6090" data-parent="#mobile-menu-dropdown">Support <span class="caret"></span></a></h4></div><!-- /.panel-heading -->
<div id="submenu-6090" class="sub-menu panel-collapse collapse">

	<div class="panel-body">
<div id="panel-item-6091" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page">	<div class="panel-heading">	<h4 id="menu-item-6091" class="panel-title" ><a title="Patreon" href="http://www.whatthebuc.net/contribute/patreon/">Patreon</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

<div id="panel-item-6092" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page">	<div class="panel-heading">	<h4 id="menu-item-6092" class="panel-title" ><a title="Donate" href="http://www.whatthebuc.net/contribute/donate/">Donate</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

<div id="panel-item-6094" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page">	<div class="panel-heading">	<h4 id="menu-item-6094" class="panel-title" ><a title="Sponsorships" href="http://www.whatthebuc.net/contribute/sponsorships/">Sponsorships</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

<div id="panel-item-6093" class="panel panel-default menu-item menu-item-type-post_type menu-item-object-page">	<div class="panel-heading">	<h4 id="menu-item-6093" class="panel-title" ><a title="Contribute" href="http://www.whatthebuc.net/contribute/">Contribute</a>	</h4></div><!-- /.panel-heading -->	</div><!-- /.panel -->

	</div><!-- .panel-body -->
</div>
</div><!-- /.panel -->

					</nav><!-- .row -->
				</div>
			</div>

			<a id="mobile-header-menu-trigger" data-toggle="collapse" href="#mobile-menu-body" class="trigger clearfix">
				<span id="mobile-header-menu-trigger-title" class="col-xxs-10 pull-left text-left site-title"><svg id="wtb-url" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 358.28 24.8"><g id="URL"><path id="W" class="cls-1" d="M0,.4H6.17l3,15a13.89,13.89,0,0,1,.3,2.52h.07A13.26,13.26,0,0,1,10,15.4L13.66.4h4.73L22,15.4a13.26,13.26,0,0,1,.4,2.52h.07a13.91,13.91,0,0,1,.3-2.52L26,.4h6.07L26,24.39H19.5l-3-12.11A20.41,20.41,0,0,1,16,9.46h-.07a20.46,20.46,0,0,1-.47,2.82l-3,12.11H5.84Z"/><path id="H" class="cls-1" d="M38.95.4h5.87V10h8.72V.4h5.87v24H53.54V15H44.82v9.4H38.95Z"/><path id="A" class="cls-1" d="M80.41,19.36H72.93l-1.44,5h-6L73.6.4h6.17l8.15,24h-6ZM76.66,5.87s-.54,2.62-1,4.13l-1.38,4.66H79L77.7,10c-.44-1.51-1-4.13-1-4.13Z"/><path id="T" class="cls-1" d="M97.29,5.44H90V.4h20.43v5h-7.28v19H97.29Z"/><path id="T-2" data-name="T" class="cls-1" d="M122.31,5.44H115V.4h20.43v5h-7.28v19h-5.87Z"/><path id="H-2" data-name="H" class="cls-1" d="M141.77.4h5.87V10h8.72V.4h5.87v24h-5.87V15h-8.72v9.4h-5.87Z"/><path id="E" class="cls-1" d="M171.22.4h15v5h-9.16V9.8h7.31v5h-7.31v4.53h9.63v5h-15.5Z"/><path id="B" class="cls-1" d="M194.3.4h8.83c4.8,0,8.15,2.15,8.15,6.27a5.86,5.86,0,0,1-2.79,5.1v.07a5.38,5.38,0,0,1,3.76,5.4c0,5.24-4.36,7.15-9.13,7.15H194.3Zm8.89,9.29a2,2,0,0,0,2.11-2.21,2,2,0,0,0-2.21-2h-2.92V9.7Zm.5,9.66a2.38,2.38,0,0,0,2.55-2.52,2.31,2.31,0,0,0-2.52-2.45h-3.56v5Z"/><path id="U" class="cls-1" d="M219.43.4h5.87V15.57c0,2.52,1.64,3.86,4.16,3.86s4.16-1.34,4.16-3.86V.4h5.87V15.57c0,5.4-4,9.23-10,9.23S219.43,21,219.43,15.57Z"/><path id="C" class="cls-1" d="M259.08,0a12.5,12.5,0,0,1,9,3.39l-2.72,4.43a10.07,10.07,0,0,0-6-2.45c-4.6,0-6.78,3.39-6.78,6.85s2.35,7.21,6.78,7.21c3.62,0,6.38-3,6.38-3l3,4.29a13.16,13.16,0,0,1-9.66,4c-7.52,0-12.58-5.33-12.58-12.45A12.2,12.2,0,0,1,259.08,0Z"/><path id="dot" class="cls-1" d="M274.78,18.89h5.5v5.5h-5.5Z"/><path id="N" class="cls-1" d="M288.2.4h5.94l6.64,11.21a43,43,0,0,1,2,4.09h.07s-.27-2.58-.27-4.09V.4h5.87v24h-5.91l-6.68-11.17a42.89,42.89,0,0,1-2-4.09h-.07s.27,2.58.27,4.09V24.39H288.2Z"/><path id="E-2" data-name="E" class="cls-1" d="M317.45.4h15v5h-9.16V9.8h7.31v5h-7.31v4.53h9.63v5h-15.5Z"/><path id="T-3" data-name="T" class="cls-1" d="M345.12,5.44h-7.28V.4h20.43v5H351v19h-5.87Z"/></g></svg></span>
				<span id="mobile-header-menu-trigger-icon" class="col-xxs-2 pull-right text-right menu-icon"><i class="fa fa-bars" aria-hidden="true"></i></span>
			</a>
		</div>

	</header><!-- Mobile Header -->

	<header id="desktop-header" class="desktop-header site-header hidden-xxs hidden-xs hidden-sm" role="banner"  data-spy="affix" data-offset-top="227">

		<div id="toolbar" class="toolbar">
			<div class="container">

				<div id="desktop-header-quicklinks" class="quicklinks col-md-8 col-lg-9 pull-left">
					<nav id="quicklinks-menu" class="menu quicklinks-menu quicklinks-nav nav text-left"><ul id="menu-quicklinks" class="menu"><li id="menu-item-14990" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14990"><a title="2018 School Supply Drive" href="http://www.whatthebuc.net/2017-school-supply-drive-2/">2018 School Supply Drive</a></li>
<li id="menu-item-6027" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6027"><a title="Patreon" href="http://www.whatthebuc.net/contribute/patreon/">Patreon</a></li>
<li id="menu-item-6026" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6026"><a title="Donate" href="http://www.whatthebuc.net/contribute/donate/">Donate</a></li>
<li id="menu-item-6023" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6023"><a title="Sponsorships" href="http://www.whatthebuc.net/contribute/sponsorships/">Sponsorships</a></li>
<li id="menu-item-6022" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6022"><a title="Contribute" href="http://www.whatthebuc.net/contribute/">Contribute</a></li>
<li id="menu-item-6021" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6021"><a title="Subscribe" href="#footer-widgets-center">Subscribe</a></li>
</ul></nav>				</div>

				<div id="site-search" class="search col-md-4 col-lg-3">
					<form role="search" method="get" id="search" class="search form search-form" action="http://www.whatthebuc.net/">
	<input type="text" value="" name="s" id="search-input" class="search input search-input" placeholder="Search" />
	<button type="submit" id="search-submit" class="search submit search-submit">
		<svg version="1.1" id="Capa_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
		     viewBox="0 0 250.313 250.313" style="enable-background:new 0 0 250.313 250.313;" xml:space="preserve">
			<g id="Search">
				<path d="M244.186,214.604l-54.379-54.378c-0.289-0.289-0.628-0.491-0.93-0.76
					c10.7-16.231,16.945-35.66,16.945-56.554C205.822,46.075,159.747,0,102.911,0S0,46.075,0,102.911
					c0,56.835,46.074,102.911,102.91,102.911c20.895,0,40.323-6.245,56.554-16.945c0.269,0.301,0.47,0.64,0.759,0.929l54.38,54.38
					c8.169,8.168,21.413,8.168,29.583,0C252.354,236.017,252.354,222.773,244.186,214.604z M102.911,170.146
					c-37.134,0-67.236-30.102-67.236-67.235c0-37.134,30.103-67.236,67.236-67.236c37.132,0,67.235,30.103,67.235,67.236
					C170.146,140.044,140.043,170.146,102.911,170.146z"/>
			</g>
		</svg>
	</button>
</form>				</div>


			</div><!-- .container -->
		</div><!-- .toolbar -->

		<div id="masthead" class="branding masthead">
			<div class="container">

				<div id="site-branding" class="branding site-branding col-xxs-12 col-xs-12 text-center">

					<a id="header-logo" href="http://www.whatthebuc.net/" title="What The Buc?" rel="home" class="logo inline-block"><img src="/wp-content/themes/whatthebuc-v2/images/what-the-buc-logo.svg" class="img-responsive" alt="What The Buc?" /></a>

					<a id="header-logo-mini" href="http://www.whatthebuc.net/" title="What The Buc?" rel="home" class="logo inline-block"><img src="/wp-content/themes/whatthebuc-v2/images/what-the-buc-logo-mini.svg" class="img-responsive" alt="What The Buc?" /></a>

				</div>

			</div><!-- .container -->
		</div><!-- #masthead -->

		<div id="header-image" class="header-image">
			<div class="container">
			</div><!-- .container -->
		</div><!-- #masthead -->

		<div id="site-navigation" class="site-navigation navigation nav-panel">
			<div class="container">
				<div class="col-xxs-12">
					<nav id="primary-menu" class="clearfix menu primary-menu primary-nav nav text-center"><ul id="primary-menu" class="menu"><li id="menu-item-6035" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-6035 dropdown"><a title="Listen" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Listen <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-6036" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6036"><a title="All Episodes" href="/podcast/">All Episodes</a></li>
	<li id="menu-item-6038" class="menu-item menu-item-type-taxonomy menu-item-object-show-type menu-item-6038"><a title="Live Shows" href="http://www.whatthebuc.net/show-type/live-shows/">Live Shows</a></li>
	<li id="menu-item-6037" class="menu-item menu-item-type-taxonomy menu-item-object-show-type menu-item-6037"><a title="Roundtables" href="http://www.whatthebuc.net/show-type/roundtables/">Roundtables</a></li>
	<li id="menu-item-6039" class="menu-item menu-item-type-taxonomy menu-item-object-show-type menu-item-6039"><a title="Watercooler" href="http://www.whatthebuc.net/show-type/watercooler/">Watercooler</a></li>
</ul>
</li>
<li id="menu-item-3089" class="blog-item menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-3089"><a title="Articles" href="http://www.whatthebuc.net/blog/">Articles</a></li>
<li id="menu-item-3350" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-3350 dropdown"><a title="Tailgate" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Tailgate <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-6032" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6032"><a title="Tailgating Zone" href="http://www.whatthebuc.net/tailgate/">Tailgating Zone</a></li>
	<li id="menu-item-3374" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3374"><a title="Rules, Notes and Updates" href="http://www.whatthebuc.net/tailgate/rules/">Rules, Notes and Updates</a></li>
	<li id="menu-item-7150" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7150"><a title="This Week&#039;s Tailgate Itinerary" href="http://www.whatthebuc.net/tailgate/weeks-tailgate-itinerary/">This Week&#8217;s Tailgate Itinerary</a></li>
	<li id="menu-item-3351" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3351"><a title="Map" href="http://www.whatthebuc.net/tailgate/map/">Map</a></li>
	<li id="menu-item-3373" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3373"><a title="Food" href="http://www.whatthebuc.net/tailgate/food/">Food</a></li>
</ul>
</li>
<li id="menu-item-11908" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11908"><a title="Our Sponsors" href="http://www.whatthebuc.net/our-sponsors/">Our Sponsors</a></li>
<li id="menu-item-3080" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-3080 dropdown"><a title="About" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">About <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-6033" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6033"><a title="About Us" href="http://www.whatthebuc.net/about/">About Us</a></li>
	<li id="menu-item-3356" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3356"><a title="The Team" href="http://www.whatthebuc.net/about/team/">The Team</a></li>
	<li id="menu-item-3355" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3355"><a title="Contact Us" href="http://www.whatthebuc.net/about/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-3354" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-3354 dropdown"><a title="WTB Really Matters" href="#" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">WTB Really Matters <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-14980" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14980"><a title="2018 School Supply Drive" href="http://www.whatthebuc.net/2017-school-supply-drive-2/">2018 School Supply Drive</a></li>
	<li id="menu-item-11489" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11489"><a title="WTB Really Matters" href="http://www.whatthebuc.net/contribute/wtb-really-matters/">WTB Really Matters</a></li>
</ul>
</li>
</ul></nav>				</div>
			</div>



		</div>
		
	</header><!-- #masthead -->

	<div id="content" class="site-content">

	<div id="primary" class="content-area single-area post-area container">

		<div class="col-xxs-12 col-xs-12 col-sm-12 col-md-10 col-lg-10 pull-right">

			<div class="row">
				<main id="main" class="site-main has-sidebar col-xxs-12 col-xs-12 col-sm-12 col-md-8 col-lg-8 pull-left" role="main">

					
<article id="post-14465" class="post-14465 post type-post status-publish format-standard has-post-thumbnail hentry category-features category-free-agency category-position-analysis tag-2018-bucs-free-agents tag-beau-allen tag-bucs-defense tag-philadelphia-eagles tag-tampa-bay-buccaneers tag-vita-vea">
	<header class="entry-header">
		<div class="entry-image" style="background-image: url(/wp-content/uploads/2018/05/N0654-TBB_1_56289501-d975-4b82-83db-53f92a12cb2f_580x.jpg); "><img src="data:image/svg+xml;charset=utf-8,%3Csvg xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg' viewBox%3D'0 0 500 300'%2F%3E" width="1280" height="720" />

			</div>		<h1 class="entry-title">Welcome Aboard, Beau Allen!</h1>		<div class="entry-meta">
			<span class="meta posted-on" title="Published On: June 23, 2018"><a href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/" rel="bookmark"><i class="fa fa-calendar" aria-hidden="true"></i> <time class="entry-date published updated" datetime="2018-06-23T08:00:54+00:00">June 23, 2018</time></a></span><span class="meta posted-author byline" title="Authored by Jon Hinkle"><span class="author vcard"><a class="url fn n" href="http://www.whatthebuc.net/author/jonhinkle/"><i class="fa fa-user" aria-hidden="true"></i> Jon Hinkle</a></span></span><span class="meta posted-categories cat-links"><i class="fa fa-folder-open-o" aria-hidden="true"></i> <a href="http://www.whatthebuc.net/category/features/" rel="category tag">Features</a>, <a href="http://www.whatthebuc.net/category/free-agency/" rel="category tag">Free Agency</a>, <a href="http://www.whatthebuc.net/category/position-analysis/" rel="category tag">Position Analysis</a></span>		</div><!-- .entry-meta -->
			</header><!-- .entry-header -->

			<div class="entry-content">
			<p>The first free agent acquisition of the 2018 offseason was a bit of a surprise. When the news came out that the <span style="color: #ff0000;">Buccaneers</span> had signed former Eagles defensive tackle <span style="color: #000000;">Beau Allen</span>, my first reaction was&#8230;<span style="color: #000000;">&#8220;WHO???&#8221;</span>.  However, after Googling him, I found that the 26-year-old Allen fits into the <span style="color: #ff0000;">Bucs</span> new blue-collar mauler philosophy for their trenches and after understanding that you begin to understand why they signed him.</p>
<p><span style="color: #000000;">Beau Christian Allen</span> was born on November 14, 1991, in Minnetonka, Minnesota. His dad, Matt Allen, was a Vikings fan. His mom, Susie Allen, was a Packers fan. I&#8217;m sure that made for an interesting family dynamic around the house on Sundays. When Beau was 12 years-old, Susie was diagnosed with breast cancer but survived. In fact, he credits his Fabio-like hairstyle to his mother&#8217;s ordeal saying <em>&#8220;It&#8217;s a reminder of what she went through&#8221;</em>  meaning the loss of her hair during chemotherapy. It started in college when he saw some of his teammates growing their hair out until it was long enough to cut and donate to cancer patients. Beau decided to follow suit and he&#8217;s only had a few<em> &#8220;trims&#8221; </em> since then.<img class="size-medium wp-image-15107 alignright" src="/wp-content/uploads/2018/06/AP_16353696528742.cb42affd.fill-735x490-300x200.jpg" alt="" width="300" height="200" srcset="/wp-content/uploads/2018/06/AP_16353696528742.cb42affd.fill-735x490-300x200.jpg 300w, /wp-content/uploads/2018/06/AP_16353696528742.cb42affd.fill-735x490-540x360.jpg 540w, /wp-content/uploads/2018/06/AP_16353696528742.cb42affd.fill-735x490.jpg 735w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<p>Beau is 6&#8217;3&#8243; and weighs 327lbs. Size and athleticism run in his family. Susie&#8217;s dad, his maternal grandfather, was 6&#8217;4&#8243; and a three-time NCAA swimming champion at the University of Wisconsin. Matt, his dad, was <em>&#8220;the runt&#8221; </em> in his family at 6&#8242; tall. His paternal grandfather was 6&#8217;4&#8243; and his uncle was 6&#8217;5&#8243; tall. He went to Minnetonka High School where he was the only player in school history to be a four-year starter. He played well enough to earn interests from several major universities including Notre Dame, Stanford, Michigan, and UCLA but chose the University of Wisconsin, his family&#8217;s alma mater. In his four years with the Badgers, he totaled <span style="color: #000000;">94 tackles</span>, <span style="color: #000000;">15 tackles for loss</span> and <span style="color: #000000;">8 sacks</span> while winning three <span style="color: #000000;">Big 10</span> championships. While in college, he was given the nickname <em>&#8220;Polar Bear&#8221;</em>.  Not sure about the story behind that. But a funny side story is that the <em>&#8220;Polar Bear&#8221;</em> dressed up in an elephant costume for Halloween one year. As a joke, he took a picture and created a <span style="color: #000000;"><em>Bumble </em></span>dating app account using it as his profile pic where he met his present girlfriend.</p>
<p>After school, he entered the <span style="color: #000000;">2014 NFL Draft</span> where he was a 7th round pick of the Philadelphia Eagles and signed a four-year deal. He only missed one game in Philly due to injury and totaled <span style="color: #000000;">87 tackles</span> and <span style="color: #000000;">2 sacks</span>. Not big numbers, but the disruption that he causes in the middle of the offensive line is immeasurable and his locker room presence is contagious. He was a huge part of an Eagles defensive line who finished <span style="color: #000000;">1st</span> in rushing defense <em>(only giving up 79.2 yards per game)</em> and <span style="color: #000000;">15th</span> in sacks with <span style="color: #000000;">38</span> for the season. Oh, and he&#8217;s also a Super Bowl champion.</p>
<p>Allen became a 2018 free agent after winning that Super Bowl. The Eagles weren&#8217;t able to re-sign him due to salary cap restraints although they wanted to, he was drawing interests from a number of other teams including the Lions and Chargers. He decided to sign with the <span style="color: #ff0000;">Buccaneers</span> for <span style="color: #000000;">three years/$15 million</span> passing up more money in higher offers from other teams to do so. There were a number of reasons that he decided to go with Tampa Bay. The scheme was similar to what they ran in Philly, the chance to be a full-time starter and the excitement of playing next to an elite player like <span style="color: #000000;">Gerald McCoy</span> seemed to be a few of the biggest though. He also said that he likes the direction that this franchise is headed with <span style="color: #000000;">Jameis Winston</span> and the rest of the young nucleus.</p>
<p>Allen is a worker. A lunch pail kind of guy. He&#8217;s been to the <em>&#8220;big dance&#8221;</em>  and understands how and what it takes to get there. Those are all things that the <span style="color: #ff0000;">Bucs</span> didn&#8217;t get from last year&#8217;s free agent defensive tackle signee <span style="color: #000000;">Chris Baker</span>. That&#8217;s why Baker is no longer here. That&#8217;s why Beau Allen is. This defense and this team are in desperate need of the brand of nasty attitude and relentless work ethic that Allen brings to the table. The <span style="color: #ff0000;">Bucs</span> 2018 first round draft pick defensive tackle <span style="color: #000000;">Vita Vea</span> may change Allen&#8217;s role in this d-line a little bit, but <span style="color: #ff0000;">Bucs</span> fans can expect Allen to come to work every day and do his job whatever it ends up being. I can&#8217;t wait to see what his addition will do for this defense that finished dead last in almost every statistical category last season.</p>
<p>Until then, as always&#8230;<span style="color: #ff0000;">GO BUCS!!!</span></p>
<p>&nbsp;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-14465" class="share-facebook sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-14465" class="share-twitter sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-14465" class="share-google-plus-1 sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div><div class="wp-about-author-containter-top" style="background-color:#FFFFFF;"><div class="wp-about-author-pic"><img alt='Jon Hinkle' src='http://www.whatthebuc.net/wp-content/uploads/2018/04/Jon-Hinkle_avatar_1522857741-100x100.jpg' class='avatar avatar-100 photo' height='100' width='100' /></div><div class="wp-about-author-text" style="margin-left:140px"><h3><a href='http://www.whatthebuc.net/author/jonhinkle/' title='Jon Hinkle'>Jon Hinkle</a></h3><p>My name is Jon Hinkle, also know as Deez Bucz to most Buccaneers fans. I have been given the opportunity by WhatTheBuc.net to do some writing about one of my favorite subjects...Buccaneer football and all that goes with it. This is my first public writing gig, so I'm hoping that I can entertain the fine fans of Tampa Bay while learning and gaining experience towards a possible new career in sports reporting. I hope everyone enjoys the fruits of my labor and I look forward to bringing some new and exciting stories to Bucs Nation! And as always.....GO BUCS!!!</p><p><a href='http://www.whatthebuc.net/author/jonhinkle/' title='More posts by Jon Hinkle'>More Posts</a> </p><p class="wpa-nomargin">Follow Me:<br /><a class='wpa-social-icons' href='http://www.twitter.com/Deez Bucz'><img src='/wp-content/plugins/wp-about-author/images/twitter.png' alt='Twitter'/></a><a class='wpa-social-icons' href='http://www.facebook.com/Deez Bucz'><img src='/wp-content/plugins/wp-about-author/images/facebook.png' alt='Facebook'/></a></p></div></div>		</div><!-- .entry-content -->
		

	<footer class="entry-footer">
			</footer><!-- .entry-footer -->
</article><!-- #post-## -->
<aside class="posts-navigation row clearfix flexbox-NULL">			<article class="previous-article col-xxs-12 col-sm-6 pull-left">
				<div class="content box">
					<div class="entry-image" style="background-image: url(/wp-content/uploads/2017/10/357171029007_Panthers_at_Bucs-1.jpg); "><a href="http://www.whatthebuc.net/2018/06/22/are-the-bucs-better-at-wide-receiver-and-tight-end/"><img src="data:image/svg+xml;charset=utf-8,%3Csvg xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg' viewBox%3D'0 0 500 300'%2F%3E" width="640" height="360" /></a></div>					<h4>Previous Article</h4>
					<h3><a href="http://www.whatthebuc.net/2018/06/22/are-the-bucs-better-at-wide-receiver-and-tight-end/" title="Are the Bucs Better at Wide Receiver and Tight End?">Are the Bucs Better at Wide Receiver and Tight End?</a></h3>
					<p class="entry-excerpt">One of the strong positions for the Bucs in 2017, the Bucs receiving core continues to make strides, but have they improved for 2018? Losses At WR, None. At TE, None. Additions At WR, Draft pick Justin Watson, UDFA's Erv...</p>
				</div>
			</article>
			</aside><!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ --><div class="fb-comments" data-href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/" data-numposts="5" data-width="100%" data-colorscheme="light"></div>


				</main><!-- #main -->

				
<aside id="sidebar" class="single-sidebar sidebar col-xxs-12 col-xs-12 col-sm-12 col-md-4 col-lg-4 pull-right">
	<div id="sidebar-content" class="content">

		<div id="now-playing" class="now-playing-widget widget-container">
	<iframe src="https://mixlr.com/users/5054489/embed" width="100%" height="180px" frameborder="no" marginwidth="0" marginheight="0" scrolling="no"></iframe>
</div>		<div class="recent-podcasts">
	<header id="recent-podcasts-header" class="recent-podcasts-header">
		<img src="data:image/svg+xml;charset=utf-8,%3Csvg xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg' viewBox%3D'0 0 500 300'%2F%3E" width="500" height="300" />
		<div class="caption">
			<h2><span class="white">Recent</span> <span class="red">Podcasts</span></h2>
		</div>
	</header>
	<div class="panel-group" id="recent-podcasts-accordion" role="tablist" aria-multiselectable="true">

					<div class="panel panel-default">
				<div class="panel-heading" role="tab" id="heading-free-agency-calm-fan-counseling-ahmazing-guests">
					<h4 class="panel-title">
						<a role="button" data-toggle="collapse" data-parent="#recent-podcasts-accordion" href="#collapse-free-agency-calm-fan-counseling-ahmazing-guests" aria-controls="collapse-free-agency-calm-fan-counseling-ahmazing-guests" aria-expanded="false" >Free Agency Calm-down, Fan Counseling and AHMAZING guests.</a>
					</h4>
				</div>
				<div id="collapse-free-agency-calm-fan-counseling-ahmazing-guests" class="panel-collapse collapse " role="tabpanel" aria-labelledby="heading-free-agency-calm-fan-counseling-ahmazing-guests">
					<div class="panel-body">
						<div class="entry-date">3/9/2018</div>
						<div class="entry-excerpt">
							<p>We&#8217;re baaaaack! Tonight, at the request of our AHMAZING fans and listeners, we talked about Free Agency, off season moves, not moves, draft and many other things that Bucs fans are talking about and, in some cases, overreacting to. What would a Pod be without great guests? Tonight I had in&#8230;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-14465" class="share-facebook sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-14465" class="share-twitter sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-14465" class="share-google-plus-1 sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div>						</div>
						<footer class="entry-footer">
							<a class="read-more btn full-width" href="http://www.whatthebuc.net/podcast/free-agency-calm-fan-counseling-ahmazing-guests/" title="Listen to Free Agency Calm-down, Fan Counseling and AHMAZING guests."><i class="fa fa-volume-up" aria-hidden="true"></i>Listen Now</a>
						</footer>
					</div>

				</div>
			</div>
						<div class="panel panel-default">
				<div class="panel-heading" role="tab" id="heading-enjoy-lump-coal-no-gruden">
					<h4 class="panel-title">
						<a role="button" data-toggle="collapse" data-parent="#recent-podcasts-accordion" href="#collapse-enjoy-lump-coal-no-gruden" aria-controls="collapse-enjoy-lump-coal-no-gruden" aria-expanded="false" >Enjoy your lump of Coal! No Gruden for YOU!</a>
					</h4>
				</div>
				<div id="collapse-enjoy-lump-coal-no-gruden" class="panel-collapse collapse " role="tabpanel" aria-labelledby="heading-enjoy-lump-coal-no-gruden">
					<div class="panel-body">
						<div class="entry-date">12/29/2017</div>
						<div class="entry-excerpt">
							<p>Joined tonight by Thomas Bassinger (@TOMetrics from the Tampa Bay Times), we discussed the latest in the Grumors saga: the end of them (or is it?) DUMB DUMB DUMB As of now, it looks like Koetter is here and he gets to try again to build a &#8220;Bad Ass football&#8230;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-14465" class="share-facebook sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-14465" class="share-twitter sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-14465" class="share-google-plus-1 sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div>						</div>
						<footer class="entry-footer">
							<a class="read-more btn full-width" href="http://www.whatthebuc.net/podcast/enjoy-lump-coal-no-gruden/" title="Listen to Enjoy your lump of Coal! No Gruden for YOU!"><i class="fa fa-volume-up" aria-hidden="true"></i>Listen Now</a>
						</footer>
					</div>

				</div>
			</div>
						<div class="panel panel-default">
				<div class="panel-heading" role="tab" id="heading-merry-christmas-gruden-chat">
					<h4 class="panel-title">
						<a role="button" data-toggle="collapse" data-parent="#recent-podcasts-accordion" href="#collapse-merry-christmas-gruden-chat" aria-controls="collapse-merry-christmas-gruden-chat" aria-expanded="false" >Merry Christmas and Gruden Chat</a>
					</h4>
				</div>
				<div id="collapse-merry-christmas-gruden-chat" class="panel-collapse collapse " role="tabpanel" aria-labelledby="heading-merry-christmas-gruden-chat">
					<div class="panel-body">
						<div class="entry-date">12/24/2017</div>
						<div class="entry-excerpt">
							<p>I made a quick Facebook live video today and then put it over on Youtube. I have also attached as a Podcast for you folks. Many of you asked my thoughts on the Gruden speculation etc. Here they are as of today. Embedded is the video for those of you&#8230;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-14465" class="share-facebook sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-14465" class="share-twitter sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-14465" class="share-google-plus-1 sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div>						</div>
						<footer class="entry-footer">
							<a class="read-more btn full-width" href="http://www.whatthebuc.net/podcast/merry-christmas-gruden-chat/" title="Listen to Merry Christmas and Gruden Chat"><i class="fa fa-volume-up" aria-hidden="true"></i>Listen Now</a>
						</footer>
					</div>

				</div>
			</div>
						<div class="panel panel-default">
				<div class="panel-heading" role="tab" id="heading-wtb-now-chris-fischer">
					<h4 class="panel-title">
						<a role="button" data-toggle="collapse" data-parent="#recent-podcasts-accordion" href="#collapse-wtb-now-chris-fischer" aria-controls="collapse-wtb-now-chris-fischer" aria-expanded="false" >WTB Do We Do Now &#8211; With Chris Fischer</a>
					</h4>
				</div>
				<div id="collapse-wtb-now-chris-fischer" class="panel-collapse collapse " role="tabpanel" aria-labelledby="heading-wtb-now-chris-fischer">
					<div class="panel-body">
						<div class="entry-date">12/17/2017</div>
						<div class="entry-excerpt">
							<p>I dragged him out too! The former host of the former podcast called Bucs Brief Podcast was with me for the whole show and we tiptoed through the topics in a way only Tiny Tim could appreciate. We covered what is going well (not much), what is going poorly (much) and&#8230;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-14465" class="share-facebook sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-14465" class="share-twitter sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-14465" class="share-google-plus-1 sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div>						</div>
						<footer class="entry-footer">
							<a class="read-more btn full-width" href="http://www.whatthebuc.net/podcast/wtb-now-chris-fischer/" title="Listen to WTB Do We Do Now &#8211; With Chris Fischer"><i class="fa fa-volume-up" aria-hidden="true"></i>Listen Now</a>
						</footer>
					</div>

				</div>
			</div>
						<div class="panel panel-default">
				<div class="panel-heading" role="tab" id="heading-rudderless-ship-lurches-forward">
					<h4 class="panel-title">
						<a role="button" data-toggle="collapse" data-parent="#recent-podcasts-accordion" href="#collapse-rudderless-ship-lurches-forward" aria-controls="collapse-rudderless-ship-lurches-forward" aria-expanded="false" >The Rudderless Ship Lurches Forward</a>
					</h4>
				</div>
				<div id="collapse-rudderless-ship-lurches-forward" class="panel-collapse collapse " role="tabpanel" aria-labelledby="heading-rudderless-ship-lurches-forward">
					<div class="panel-body">
						<div class="entry-date">12/8/2017</div>
						<div class="entry-excerpt">
							<p>There is no silver lining. The highs are things we should expect and the lows are still shocking. Add a does od grouchy bullshit from the leadership and a lack of direction and the result is a stadium serving crappy food with bad entertainment. We have already lived through that&#8230;.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-14465" class="share-facebook sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-14465" class="share-twitter sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-14465" class="share-google-plus-1 sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div>						</div>
						<footer class="entry-footer">
							<a class="read-more btn full-width" href="http://www.whatthebuc.net/podcast/rudderless-ship-lurches-forward/" title="Listen to The Rudderless Ship Lurches Forward"><i class="fa fa-volume-up" aria-hidden="true"></i>Listen Now</a>
						</footer>
					</div>

				</div>
			</div>
			
	</div>
</div>
		
			<ul class="single-widgets widgets">
				<li id="archives-4" class="widget-container widget_archive"><h3 class="widget-title">Article Archives</h3>		<label class="screen-reader-text" for="archives-dropdown-4">Article Archives</label>
		<select id="archives-dropdown-4" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='http://www.whatthebuc.net/2018/06/'> June 2018 &nbsp;(8)</option>
	<option value='http://www.whatthebuc.net/2018/05/'> May 2018 &nbsp;(12)</option>
	<option value='http://www.whatthebuc.net/2018/04/'> April 2018 &nbsp;(32)</option>
	<option value='http://www.whatthebuc.net/2018/03/'> March 2018 &nbsp;(23)</option>
	<option value='http://www.whatthebuc.net/2018/02/'> February 2018 &nbsp;(2)</option>
	<option value='http://www.whatthebuc.net/2018/01/'> January 2018 &nbsp;(5)</option>
	<option value='http://www.whatthebuc.net/2017/12/'> December 2017 &nbsp;(12)</option>
	<option value='http://www.whatthebuc.net/2017/11/'> November 2017 &nbsp;(15)</option>
	<option value='http://www.whatthebuc.net/2017/10/'> October 2017 &nbsp;(26)</option>
	<option value='http://www.whatthebuc.net/2017/09/'> September 2017 &nbsp;(16)</option>
	<option value='http://www.whatthebuc.net/2017/08/'> August 2017 &nbsp;(27)</option>
	<option value='http://www.whatthebuc.net/2017/07/'> July 2017 &nbsp;(17)</option>
	<option value='http://www.whatthebuc.net/2017/06/'> June 2017 &nbsp;(21)</option>
	<option value='http://www.whatthebuc.net/2017/05/'> May 2017 &nbsp;(13)</option>
	<option value='http://www.whatthebuc.net/2017/04/'> April 2017 &nbsp;(10)</option>
	<option value='http://www.whatthebuc.net/2017/03/'> March 2017 &nbsp;(10)</option>
	<option value='http://www.whatthebuc.net/2017/02/'> February 2017 &nbsp;(4)</option>
	<option value='http://www.whatthebuc.net/2017/01/'> January 2017 &nbsp;(4)</option>
	<option value='http://www.whatthebuc.net/2016/12/'> December 2016 &nbsp;(10)</option>
	<option value='http://www.whatthebuc.net/2016/11/'> November 2016 &nbsp;(20)</option>
	<option value='http://www.whatthebuc.net/2016/10/'> October 2016 &nbsp;(18)</option>
	<option value='http://www.whatthebuc.net/2016/09/'> September 2016 &nbsp;(24)</option>
	<option value='http://www.whatthebuc.net/2016/08/'> August 2016 &nbsp;(10)</option>
	<option value='http://www.whatthebuc.net/2016/07/'> July 2016 &nbsp;(2)</option>
	<option value='http://www.whatthebuc.net/2016/06/'> June 2016 &nbsp;(3)</option>
	<option value='http://www.whatthebuc.net/2016/05/'> May 2016 &nbsp;(1)</option>
	<option value='http://www.whatthebuc.net/2016/04/'> April 2016 &nbsp;(2)</option>
	<option value='http://www.whatthebuc.net/2016/01/'> January 2016 &nbsp;(2)</option>
	<option value='http://www.whatthebuc.net/2015/11/'> November 2015 &nbsp;(9)</option>
	<option value='http://www.whatthebuc.net/2015/10/'> October 2015 &nbsp;(5)</option>
	<option value='http://www.whatthebuc.net/2015/09/'> September 2015 &nbsp;(19)</option>
	<option value='http://www.whatthebuc.net/2015/08/'> August 2015 &nbsp;(14)</option>
	<option value='http://www.whatthebuc.net/2015/07/'> July 2015 &nbsp;(2)</option>
	<option value='http://www.whatthebuc.net/2015/06/'> June 2015 &nbsp;(6)</option>
	<option value='http://www.whatthebuc.net/2015/05/'> May 2015 &nbsp;(4)</option>
	<option value='http://www.whatthebuc.net/2015/04/'> April 2015 &nbsp;(1)</option>
	<option value='http://www.whatthebuc.net/2015/03/'> March 2015 &nbsp;(2)</option>
	<option value='http://www.whatthebuc.net/2014/12/'> December 2014 &nbsp;(11)</option>
	<option value='http://www.whatthebuc.net/2014/11/'> November 2014 &nbsp;(8)</option>
	<option value='http://www.whatthebuc.net/2014/10/'> October 2014 &nbsp;(8)</option>
	<option value='http://www.whatthebuc.net/2014/09/'> September 2014 &nbsp;(15)</option>
	<option value='http://www.whatthebuc.net/2014/08/'> August 2014 &nbsp;(10)</option>
	<option value='http://www.whatthebuc.net/2014/07/'> July 2014 &nbsp;(9)</option>
	<option value='http://www.whatthebuc.net/2014/06/'> June 2014 &nbsp;(3)</option>
	<option value='http://www.whatthebuc.net/2014/05/'> May 2014 &nbsp;(4)</option>
	<option value='http://www.whatthebuc.net/2014/03/'> March 2014 &nbsp;(1)</option>
	<option value='http://www.whatthebuc.net/2014/01/'> January 2014 &nbsp;(1)</option>
	<option value='http://www.whatthebuc.net/2013/12/'> December 2013 &nbsp;(1)</option>
	<option value='http://www.whatthebuc.net/2013/10/'> October 2013 &nbsp;(5)</option>
	<option value='http://www.whatthebuc.net/2013/09/'> September 2013 &nbsp;(5)</option>
	<option value='http://www.whatthebuc.net/2013/08/'> August 2013 &nbsp;(5)</option>
	<option value='http://www.whatthebuc.net/2013/07/'> July 2013 &nbsp;(10)</option>
	<option value='http://www.whatthebuc.net/2013/06/'> June 2013 &nbsp;(2)</option>
	<option value='http://www.whatthebuc.net/2013/05/'> May 2013 &nbsp;(1)</option>
	<option value='http://www.whatthebuc.net/2013/03/'> March 2013 &nbsp;(1)</option>
	<option value='http://www.whatthebuc.net/2013/02/'> February 2013 &nbsp;(1)</option>
	<option value='http://www.whatthebuc.net/2012/12/'> December 2012 &nbsp;(2)</option>
	<option value='http://www.whatthebuc.net/2012/09/'> September 2012 &nbsp;(6)</option>
	<option value='http://www.whatthebuc.net/2012/08/'> August 2012 &nbsp;(4)</option>
	<option value='http://www.whatthebuc.net/2012/07/'> July 2012 &nbsp;(10)</option>
	<option value='http://www.whatthebuc.net/2012/06/'> June 2012 &nbsp;(3)</option>
	<option value='http://www.whatthebuc.net/2012/05/'> May 2012 &nbsp;(13)</option>
	<option value='http://www.whatthebuc.net/2012/04/'> April 2012 &nbsp;(23)</option>
	<option value='http://www.whatthebuc.net/2012/03/'> March 2012 &nbsp;(2)</option>
	<option value='http://www.whatthebuc.net/2012/02/'> February 2012 &nbsp;(2)</option>
	<option value='http://www.whatthebuc.net/2012/01/'> January 2012 &nbsp;(6)</option>
	<option value='http://www.whatthebuc.net/2011/12/'> December 2011 &nbsp;(11)</option>
	<option value='http://www.whatthebuc.net/2011/11/'> November 2011 &nbsp;(12)</option>
	<option value='http://www.whatthebuc.net/2011/10/'> October 2011 &nbsp;(14)</option>
	<option value='http://www.whatthebuc.net/2011/09/'> September 2011 &nbsp;(20)</option>
	<option value='http://www.whatthebuc.net/2011/08/'> August 2011 &nbsp;(21)</option>
	<option value='http://www.whatthebuc.net/2011/07/'> July 2011 &nbsp;(10)</option>
	<option value='http://www.whatthebuc.net/2011/06/'> June 2011 &nbsp;(1)</option>
	<option value='http://www.whatthebuc.net/2011/05/'> May 2011 &nbsp;(3)</option>
	<option value='http://www.whatthebuc.net/2011/04/'> April 2011 &nbsp;(3)</option>
	<option value='http://www.whatthebuc.net/2011/03/'> March 2011 &nbsp;(11)</option>
	<option value='http://www.whatthebuc.net/2011/02/'> February 2011 &nbsp;(4)</option>
	<option value='http://www.whatthebuc.net/2011/01/'> January 2011 &nbsp;(1)</option>
	<option value='http://www.whatthebuc.net/2010/12/'> December 2010 &nbsp;(14)</option>
	<option value='http://www.whatthebuc.net/2010/11/'> November 2010 &nbsp;(15)</option>
	<option value='http://www.whatthebuc.net/2010/10/'> October 2010 &nbsp;(20)</option>
	<option value='http://www.whatthebuc.net/2010/09/'> September 2010 &nbsp;(23)</option>
	<option value='http://www.whatthebuc.net/2010/08/'> August 2010 &nbsp;(23)</option>
	<option value='http://www.whatthebuc.net/2010/07/'> July 2010 &nbsp;(8)</option>
	<option value='http://www.whatthebuc.net/2010/06/'> June 2010 &nbsp;(7)</option>
	<option value='http://www.whatthebuc.net/2010/05/'> May 2010 &nbsp;(2)</option>
	<option value='http://www.whatthebuc.net/2010/04/'> April 2010 &nbsp;(6)</option>
	<option value='http://www.whatthebuc.net/2010/03/'> March 2010 &nbsp;(5)</option>
	<option value='http://www.whatthebuc.net/2010/02/'> February 2010 &nbsp;(17)</option>
	<option value='http://www.whatthebuc.net/2010/01/'> January 2010 &nbsp;(12)</option>
	<option value='http://www.whatthebuc.net/2009/12/'> December 2009 &nbsp;(19)</option>
	<option value='http://www.whatthebuc.net/2009/11/'> November 2009 &nbsp;(21)</option>
	<option value='http://www.whatthebuc.net/2009/10/'> October 2009 &nbsp;(24)</option>
	<option value='http://www.whatthebuc.net/2009/09/'> September 2009 &nbsp;(27)</option>
	<option value='http://www.whatthebuc.net/2009/08/'> August 2009 &nbsp;(29)</option>

		</select>
		</li><li id="wppress_facebook_calendar_widget-3" class="widget-container widget_wppress_facebook_calendar_widget"><h3 class="widget-title">Upcoming Events</h3><div class="fb-event-calendar" data-user-id="51084105572,1547185695550956,1547185695550956" data-include-attending="no" data-show-list="" data-calendar-step="" data-hide-past-events="yes" data-mode="default" data-show-in-popup="yes" data-template="fb-calendar-template-5b2f6469ebfd8"></div>
<script type="text/template" id="fb-calendar-template-5b2f6469ebfd8">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</script>
<script type="text/javascript">jQuery(document).ready(function($){typeof WPPress._initFB_calendar=="function" && WPPress._initFB_calendar();});</script></li><li id="linkcat-13" class="widget-container widget_links"><h3 class="widget-title">Broadcast Partners</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://www.pewterreport.com" title="Great Bucs coverage! Become an Insider!">Pewter Report</a></li>

	</ul>
</li>
<li id="linkcat-2" class="widget-container widget_links"><h3 class="widget-title">Friends of WTB</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://creativetravelgroup.com/services/bucfan-tours/" rel="friend met colleague" title="Best way to see our Bucs on the Road! " target="_blank">Buc Fan Tours</a></li>
<li><a href="http://www.bucstats.com" target="_blank">Buc Stats</a></li>
<li><a href="http://www.bucsnation.com" target="_blank">Bucs Nation</a></li>
<li><a href="http://www.joebucsfan.com" title="Terrific Bucs site with a different spin.">Joe BucsFan</a></li>
<li><a href="http://www.pewterreport.com" title="Great Bucs coverage! Become an Insider!">Pewter Report</a></li>

	</ul>
</li>
			</ul>
		
			</div>
</aside>			</div>

		</div>
		
<aside id="sponsors" class="single-sidebar sidebar col-xxs-12 col-xs-12 col-sm-12 col-md-2 col-lg-2 pull-left">
	<div id="sponsors-content" class="content row">

		
	        <ul class="sponsors-widgets widgets">
	            <li id="ajdg_grpwidgets-2" class="widget-container ajdg_grpwidgets"><h3 class="widget-title">Our Sponsors</h3><ul><li><div class="g g-2"><div class="g-col b-2 a-40"><a class="gofollow" data-track="NDAsMiwxLDYw" href="http://www.adrotateforwordpress.com"><img src="/wp-content/uploads/2017/09/1.jpg" /></a></div></div><div class="g g-2"><div class="g-col b-2 a-17"><a class="gofollow" data-track="MTcsMiwxLDYw" href="http://www.adrotateforwordpress.com"><img src="/wp-content/uploads/2016/09/Skyscraper.jpg" /></a></div></div><div class="g g-2"><div class="g-col b-2 a-38"><a class="gofollow" data-track="MzgsMiwxLDYw" href="http://www.adrotateforwordpress.com"><img src="/wp-content/uploads/2016/09/Fat-Skyscraper.jpg" /></a></div></div><div class="g g-2"><div class="g-col b-2 a-27"><a class="gofollow" data-track="MjcsMiwxLDYw" href="http://www.steakhouseelite.com/"><img src="http://www.WhatTheBuc.net/wp-content/uploads/2014/09/rsz_steakhousesq.jpg" /></a></div></div></li></ul></li>	        </ul>

	    	</div>
</aside>
	</div><!-- #primary -->


	</div><!-- #content -->

	<footer id="colophon" class="site-footer" role="contentinfo">

		<div id="footer-tagline-row" class="clearfix">
			<div class="container">
				<div id="tagline" class="col-xxs-12 text-center">
					<div class="content">
						We Are Not A Question, We Are The Answer
					</div>
				</div><!-- #copyright -->
			</div>
		</div>
		
		<div id="footer-navigation-row" class="clearfix">
		    <div class="container">

			    <div id="footer-widgets-left" class="footer-widgets-left widgets-left col-xxs-12 col-xs-12 col-lg-9 pull-left">
				    <div class="row">

					    <div id="footer-logo-row" class="col-xxs-12 col-xs-12 col-sm-4 col-md-4 col-lg-4 col-xl-3 pull-left">
						    <div class="content">
							    <a id="footer-logo" href="http://www.whatthebuc.net/" title="What The Buc?" rel="home" class="logo inline-block"><img src="/wp-content/themes/whatthebuc-v2/images/what-the-buc-logo-light.svg" class="img-responsive" alt="What The Buc?" /></a>

							    <nav id="social-menu" class="menu social-menu social-nav nav navigation"><ul id="menu-social-links" class="menu"><li id="menu-item-5402" class="facebook menu-item menu-item-type-custom menu-item-object-custom social"><a title="Like Us on Facebook" target="_blank" href="https://www.facebook.com/whatthebuc"><span class="sr-only text">Facebook</span></a></li>
<li id="menu-item-5403" class="twitter menu-item menu-item-type-custom menu-item-object-custom social"><a title="Follow Us on Twitter" target="_blank" href="https://twitter.com/whatthebuc"><span class="sr-only text">Twitter</span></a></li>
<li id="menu-item-5404" class="youtube menu-item menu-item-type-custom menu-item-object-custom social"><a title="Watch Our YouTube Videos" target="_blank" href="https://www.youtube.com/user/WhatTheBuc"><span class="sr-only text">YouTube</span></a></li>
<li id="menu-item-5405" class="instagram menu-item menu-item-type-custom menu-item-object-custom social"><a title="See Our Instagram Photos" target="_blank" href="https://www.instagram.com/whatthebuc/"><span class="sr-only text">Instagram</span></a></li>
</ul></nav>
							    <ul class="widgets">
								    							    </ul>
						    </div>
					    </div>

					    <div id="footer-widgets-center" class="col-xxs-12 col-xs-12 col-sm-8 col-md-8 col-lg-8 col-xl-9 pull-left">
						    <div class="content">
							    <span class="dualbrain_summary footer-summary"><p>This is the home of Fan-Based Tampa Bay Buccaneers discussion! We cover the Tampa Bay Area sports scene from the perspective of the informed fans. There are plenty of places to hear about the <a href="http://www.buccaneers.com" target="_blank">Buccaneers</a>,  but "What the Buc?" is the ONLY place to hear Bucs Radio from the heart and from lifelong fans! Come join our site and our broadcast and we will share our opinions about the team, directions and the excitement of following the <a href="http://www.buccaneers.com" target="_blank">Tampa Bay Buccaneers</a>!</p>
</span>

							    <ul class="widgets">
								    <li id="mc4wp_form_widget-2" class="widget-container widget_mc4wp_form_widget"><h3 class="widget-title">Join The Krew</h3><script>(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><!-- MailChimp for WordPress v4.2.2 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-5720" method="post" data-id="5720" data-name="Newsletter Signup" ><div class="mc4wp-form-fields"><div class="row">
  <div class="col col-xxs-12 col-xs-12 col-sm-6">
    <label for="FNAME" class="sr-only">First Name</label>
    <input type="text" name="FNAME" id="FNAME" placeholder="FIRST NAME" class="full-width" required>
  </div>
  <div class="col col-xxs-12 col-xs-12 col-sm-6">
    <label for="LNAME" class="sr-only">Last Name</label>
    <input type="text" name="LNAME" id="LNAME" placeholder="LAST NAME" class="full-width" required>
  </div>
</div>
<div class="row">
  <div class="col col-xxs-12 col-xs-12 col-sm-7">
    <label for="EMAIL" class="sr-only">Email</label>
    <input type="email" name="EMAIL" placeholder="EMAIL" id="EMAIL" class="full-width" required />
  </div>
  <div class="col col-xxs-12 col-xs-12 col-sm-5">
    <input type="submit" value="SUBSCRIBE" class="btn full-width" />
  </div>
</div></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1529832554" /><input type="hidden" name="_mc4wp_form_id" value="5720" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / MailChimp for WordPress Plugin --></li>							    </ul>

						    </div>
					    </div>



				    </div>
			    </div>

			    <div id="footer-widgets-right" class="footer-widgets-right widgets-right col-xxs-12 col-xs-12 col-lg-3 pull-right">
				    <div class="content">
					    <ul class="widgets">
						    <li id="linkcat-2" class="widget-container widget_links"><h3 class="widget-title">Friends of WTB</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://creativetravelgroup.com/services/bucfan-tours/" rel="friend met colleague" title="Best way to see our Bucs on the Road! " target="_blank">Buc Fan Tours</a></li>
<li><a href="http://www.bucstats.com" target="_blank">Buc Stats</a></li>
<li><a href="http://www.bucsnation.com" target="_blank">Bucs Nation</a></li>
<li><a href="http://www.joebucsfan.com" title="Terrific Bucs site with a different spin.">Joe BucsFan</a></li>
<li><a href="http://www.pewterreport.com" title="Great Bucs coverage! Become an Insider!">Pewter Report</a></li>

	</ul>
</li>
					    </ul>
				    </div>
			    </div>
				
		    </div><!-- .container -->
	    </div><!-- #footer-navigation-row -->
		
		
		<div id="footer-about-row" >
	        <div class="container clearfix">

		        <div id="copyright" class="col-xxs-12 text-center">
			        <div class="content">
				        <span class="dualbrain_copyright copyright"><p>WhatTheBuc.net is a fansite of the Tampa Bay Buccaneers, intended for the the enjoyment of fans of the Bucs. The site is not afilliated with the Tampa Bay Buccaneers or the National Football League. All logos used are trademarks of the Tampa Bay Buccaneers, the N.F.L. and associated franchises.</p>
<p>All content Copyright © 2009 &#8211; 2016 What the Buc Really Matters Foundation, Inc. WhatTheBuc.net</p>
<p>Site design and development by Dual Brain</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-14465" class="share-facebook sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-14465" class="share-twitter sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-14465" class="share-google-plus-1 sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon" href="http://www.whatthebuc.net/2018/06/23/welcome-aboard-beau-allen/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div></span>
			        </div>
		        </div><!-- #copyright -->

	        </div><!-- .container -->
        </div><!-- #footer-copyright-row -->
	
	</footer><!-- #colophon -->
</div><!-- #page -->

<script>(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script>	<script type="text/javascript">
		var c = document.body.className;
		c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
		document.body.className = c;
	</script>
	
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.whatthebuc.net\/2018\/06\/23\/welcome-aboard-beau-allen\/":14465};
	</script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201825'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"http:\/\/www.whatthebuc.net\/shop\/cart\/","is_cart":"","cart_redirect_after_add":"yes"};
/* ]]> */
</script>
<script type='text/javascript' src='/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=3.4.1'></script>
<script type='text/javascript' src='/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70'></script>
<script type='text/javascript' src='/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=3.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_8a7c8b0cfa83ebf6803d07275795b100","fragment_name":"wc_fragments_8a7c8b0cfa83ebf6803d07275795b100"};
/* ]]> */
</script>
<script type='text/javascript' src='/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=3.4.1'></script>
<script type='text/javascript' src='/wp-content/themes/whatthebuc-v2/js/bootstrap.min.js?ver=3.3.6'></script>
<script type='text/javascript' src='/wp-content/themes/whatthebuc-v2/js/navigation.js?ver=2.1'></script>
<script type='text/javascript' src='/wp-content/themes/whatthebuc-v2/js/mejs-feature-fontawesome.min.js?ver=2.1'></script>
<script type='text/javascript' src='/wp-content/themes/whatthebuc-v2/js/skip-link-focus-fix.js?ver=2.1'></script>
<script type='text/javascript' src='/wp-content/plugins/wp-featherlight/js/wpFeatherlight.pkgd.min.js?ver=1.2.0'></script>
<script type='text/javascript' src='http://www.whatthebuc.net/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='/wp-content/plugins/facebook-events/js/script.min.js?ver=4.9.9'></script>
<script type='text/javascript' src='http://www.whatthebuc.net/wp-includes/js/wp-embed.min.js?ver=4.9.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type='text/javascript' src='/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js?ver=4.2.2'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.2.2'></script>
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.1.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=836997632991653&version=v2.3";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<script type='text/javascript' src='https://stats.wp.com/e-201825.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.1.1',blog:'70563024',post:'14465',tz:'-4',srv:'www.whatthebuc.net'} ]);
	_stq.push([ 'clickTrackerInit', '70563024', '14465' ]);
</script>

</body>
</html>
